BTC Send and Receive Unavailable
Incident Report for CoinCorner
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 14, 2018 - 11:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Sep 14, 2018 - 09:19 UTC
This incident affected: Bitcoin Services (Send Bitcoin, Receive Bitcoin).