Network Backlog
Incident Report for CoinCorner
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 29, 2017 - 12:25 UTC
Monitoring
There is currently a backlog of transactions on the bitcoin blockchain. This will potentially cause delays on transaction confirmations.
Posted over 1 year ago. Aug 23, 2017 - 12:51 UTC