GBP Bank Deposit and Withdrawal Services Currently Unavailable
Incident Report for CoinCorner
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Sep 14, 2018 - 09:21 UTC
Monitoring
GBP Bank Deposit and Withdrawal Services are currently unavailable whilst our Bank change their GBP Correspondent Bank. We have no advice on when these Services will resume, but please rest assured that our Bank are working as hard as possible to restore them.

NOTE: If you wish to withdraw your GBP balance you can now use our new card withdrawal service.
Posted about 1 year ago. Oct 17, 2017 - 14:29 UTC