Bitcoin wallet down for maintenance
Incident Report for CoinCorner
Resolved
This incident has been resolved.
Posted 12 months ago. Nov 10, 2017 - 12:38 UTC
Identified
Bitcoin sends and receives are currently unavailable during wallet maintenance.
Posted 12 months ago. Nov 03, 2017 - 20:27 UTC